SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000528: pppcall fifo syncorinsation blocking issue - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000528Endian FirewallNetwork related (VPN, uplinks)public2008-01-28 19:162008-02-02 07:28
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityblockReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta2 
Target Version2.2-beta3Fixed in Version2.2-beta3 
Summary0000528: pppcall fifo syncorinsation blocking issue
Descriptionassume pppcall has been started by the uplinks script and pppcall started pppd.

another process calls uplinks stop, which tears down the same uplink. The stop script kills the pppd process (TERM) and sends notifications to uplinksdaemon and pppcall (process A).
Since pppd has been terminated and should exit, it calls ip-down, which also sends notifications and writes to the fifo (process B).

In that moment it is not synchronized which process writes first to the pppcall fifo, therefore it happens that both processes (A and B) write to the fifo at the same time.

One process, let's say process A will successfully write to the fifo, which causes pppcall to exit.
after pppcall successfully get a notification message from the fifo it tries to destroy the fifo before exiting.
This will not work, because the fifo is open by process B, which tries to write to it.

Since pppcall exits there is no fifo reader and process B will wait infinitely during write.


Possible (?) solution: send the pppcall notification only if the PPID is that one of the pppd process.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-01-28 19:16 peter-endian New Issue
2008-01-28 19:16 peter-endian Status new => assigned
2008-01-28 19:16 peter-endian Assigned To => peter-endian
2008-01-28 19:17 peter-endian Severity minor => block
2008-01-28 19:17 peter-endian Target Version => 2.2-beta3
2008-01-30 15:17 peter-endian Status assigned => resolved
2008-01-30 15:17 peter-endian Fixed in Version => 2.2-beta3
2008-01-30 15:17 peter-endian Resolution open => fixed
2008-02-02 07:28 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker