SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000538: FTP Antivirus not working - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000538Endian FirewallApplication Level Proxiespublic2008-02-02 18:002008-10-16 09:43
Reporterbodo olschewski 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version2.2-beta3 
Target Version2.3Fixed in Version2.2-rc3 
Summary0000538: FTP Antivirus not working
DescriptionEverytime I activate FTP Antivirus I'm not able to connect to external FTP-servers anymore. After disable, i can connect the servers again.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000290closedra-endian ftp proxy not working . 
has duplicate 0001373closed frox donĀ“t work 
related to 0001155closed frox need to use squid as parent proxy 

-  Notes
(0001070)
bodo olschewski (reporter)
2008-04-24 21:25

Hello,

also in 2.2b4 the problem still exists.
(0001164)
bodo olschewski (reporter)
2008-05-14 11:53

Hello,

same problem in 2.2RC1.
Without FTP proxy ftp works fine, after activating, the ftp client can not read the directory at login anymore (Windows commander).
(0001170)
nikolai (reporter)
2008-05-14 17:19

gleiche problem bei mir (rc1)
(0001254)
migiandone (reporter)
2008-05-30 15:56

same problem on mine 2.2rc1
(0001263)
rav3n (reporter)
2008-06-03 08:37

Same problem here
(0001715)
luca-endian (developer)
2008-10-16 09:13

Confirmed on dev firewall with this packages version:
Name: efw-frox
Version: 1:2.2.16-0.endian4@i586
Name: frox
Version: 0.7.18-0.endian3@i386
(0001716)
chris-endian (reporter)
2008-10-16 09:42

Hi,

EFW supports transparent ftp proxying with frox if and only if EFW is directly
connected to the internet.

If you have another NATing firewall or router between EFW and the internet,
frox doesn't work because it uses an active ftp upstream that the other NAT
doesn't know about.

We won't fix this, hence I'm closing this bug.

Bye,
Chris.

- Issue History
Date Modified Username Field Change
2008-02-02 18:00 bodo olschewski New Issue
2008-02-04 14:42 ra-endian Relationship added duplicate of 0000290
2008-02-28 15:48 ra-endian Status new => resolved
2008-02-28 15:48 ra-endian Fixed in Version => 2.2-rc1
2008-02-28 15:48 ra-endian Resolution open => fixed
2008-02-28 15:48 ra-endian Assigned To => ra-endian
2008-03-04 14:43 ra-endian Fixed in Version 2.2-rc1 => 2.2-beta4
2008-04-23 17:42 peter-endian Status resolved => closed
2008-04-24 21:25 bodo olschewski Status closed => feedback
2008-04-24 21:25 bodo olschewski Resolution fixed => reopened
2008-04-24 21:25 bodo olschewski Note Added: 0001070
2008-05-14 11:53 bodo olschewski Note Added: 0001164
2008-05-14 17:19 nikolai Note Added: 0001170
2008-05-15 11:15 peter-endian Target Version => 2.2
2008-05-30 15:56 migiandone Note Added: 0001254
2008-06-03 08:37 rav3n Note Added: 0001263
2008-06-29 06:43 raphael-endian Severity minor => major
2008-07-23 11:23 peter-endian Relationship added related to 0001155
2008-09-10 15:41 chris-endian Target Version 2.2 => 2.3
2008-10-16 09:13 luca-endian Note Added: 0001715
2008-10-16 09:42 chris-endian Note Added: 0001716
2008-10-16 09:43 chris-endian Status feedback => closed
2008-10-16 09:43 chris-endian Resolution reopened => won't fix
2008-10-16 09:43 chris-endian Fixed in Version 2.2-beta4 => 2.2-rc3
2008-10-16 10:43 luca-endian Relationship added has duplicate 0001373

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker