SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000630: zonefw: traffic from one interface to another of the same bridg can't be blocked - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000630Endian FirewallFirewall (iptables)public2008-03-22 23:012008-04-23 17:41
Reporterpeter-endian 
Assigned Topeter-endian 
PriorityurgentSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta3 
Target Version2.2-beta4Fixed in Version2.2-beta4 
Summary0000630: zonefw: traffic from one interface to another of the same bridg can't be blocked
Descriptionpresume interface1 and interface2 are member of GREEN (br0), and you have ACCEPT GREEN > GREEN within zonefw
and want to create a rule which denies traffic from interface1 to interface2, this will not work.

it's because ZONEFW creates such rules:
ACCEPT all -- * br0 PHYSDEV match --physdev-in eth1
ACCEPT all -- * br0 PHYSDEV match --physdev-in eth2

because it will take the decision through marks to ebtables.

but this is bridge traffic! physdev-out might be necessary here.
within ebtables it passes the FORWARD chain, not OUTGOING, and the interfaces
maybe are not to be specified with -o but with --logical-out
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-03-22 23:01 peter-endian New Issue
2008-03-22 23:01 peter-endian Status new => assigned
2008-03-22 23:01 peter-endian Assigned To => peter-endian
2008-04-02 22:01 peter-endian Priority normal => urgent
2008-04-17 14:58 peter-endian Status assigned => resolved
2008-04-17 14:58 peter-endian Fixed in Version => 2.2-beta4
2008-04-17 14:58 peter-endian Resolution open => fixed
2008-04-23 17:41 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker