SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000662: Port forwarding / NAT does not forward to WEB server on GREEN interface - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000662Endian FirewallFirewall (iptables)public2008-04-07 18:492008-06-03 12:35
Reporterpapoux_gallant 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version2.2-beta3 
Target VersionFixed in Version2.2-rc1 
Summary0000662: Port forwarding / NAT does not forward to WEB server on GREEN interface
DescriptionDear EFW support,

I'm trying to setup a WEB server (TCP port 80) on the GREEN interface side.
I setup a Port forwarding / NAT rule to redirect all packets with matching uplink IP Address and destination TCP port 80 to my server.

Unfortunately, all packets are blocked by the ebtables rules. Packets are properly natted. I validated it using statistics counters of iptables -n -t nat -v -L. Packets are properly filtered. I validated it using statistics counters iptables -v -n -t filter -L and tcpdump -i br0. When doing a tcpdump -i eth0, the same packets that were accepted on br0 were not bridged on eth0... I flushed all ebtables rules and everything works!

Best regards,

Paul Gallant
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000543closedpeter-endian Port Forwarding not working 
duplicate of 0000720closedpeter-endian no NAT after upgrade 2.2b3 to 2.2b4 

-  Notes
(0000976)
peter-endian (administrator)
2008-04-08 07:58

This most probably has already been fixed. Unfortunately we can't provide an update right now. Need to wait until beta4 will be released
(0000980)
papoux_gallant (reporter)
2008-04-09 13:55

Dear Peter,

I'm unable to find a schedule or a timeline on Endian Firewall WEB site with desired features and bug fixes for each release. Do you have a scheduled date for EFW beta4 release?

Best regards,

Paul Gallant
(0001036)
peter-endian (administrator)
2008-04-24 09:35

it's released now.
Is this still an issue?
(0001113)
jsalgado (reporter)
2008-05-02 19:52

Hi Petter, I did verify this same issue on Beta3, I waited for Beta4, and now they Issue has inverted, now green is unable to reach the internet! This is a real mayor issue because, the least feature wanted from a firewall router is to route out of the box. =)

I am surprised there arent a bunch of reports on that.
Could this have to do with the hardware technology, I am using a Celeron 800Mhz and there is no internet access at all, even thou the uplink is up (PPPoE) and the endian box reaches the internet and resolves DNS querys very good, No machine on the lan has internet access.

 I am using a rather old machine but endian 2.1.2 worked alright even with a Via C3 600mhz?
(0001271)
papoux_gallant (reporter)
2008-06-03 12:35

Fixed & Validated in Version 2.2RC1
(0001272)
papoux_gallant (reporter)
2008-06-03 12:35

Fixed & Resolved in Version 2.2RC1

- Issue History
Date Modified Username Field Change
2008-04-07 18:49 papoux_gallant New Issue
2008-04-07 18:49 papoux_gallant Status new => assigned
2008-04-07 18:49 papoux_gallant Assigned To => peter-endian
2008-04-08 07:57 peter-endian Relationship added duplicate of 0000543
2008-04-08 07:58 peter-endian Note Added: 0000976
2008-04-09 13:55 papoux_gallant Note Added: 0000980
2008-04-24 09:35 peter-endian Note Added: 0001036
2008-04-24 09:35 peter-endian Status assigned => feedback
2008-05-02 19:52 jsalgado Note Added: 0001113
2008-05-09 17:12 peter-endian Relationship added duplicate of 0000720
2008-05-09 17:12 peter-endian Duplicate ID 0 => 720
2008-05-09 17:12 peter-endian Status feedback => resolved
2008-05-09 17:12 peter-endian Fixed in Version => 2.2-rc1
2008-05-09 17:12 peter-endian Resolution open => duplicate
2008-06-03 12:35 papoux_gallant Note Added: 0001271
2008-06-03 12:35 papoux_gallant Status resolved => confirmed
2008-06-03 12:35 papoux_gallant Status confirmed => closed
2008-06-03 12:35 papoux_gallant Note Added: 0001272

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker