SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000675: Can't Install - "error reading target_device - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000675Endian FirewallInstallationpublic2008-04-11 10:212009-10-27 12:00
ReporterRalf 
Assigned Topeter-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta3 
Target Version2.3Fixed in Version2.3 
Summary0000675: Can't Install - "error reading target_device
DescriptionWhile trying to install 2.2 Beta 3 the error message "error reading target_device" then "your harddrive is too small" followed by "OK to reboot" appears.
Worked fine with endian 2.1.2
Additional InformationHardware:
Compaq ProLiant DL360
Integrated Smart Array Controller ver 1.42
2 x 18 GB SCSI in RAID 1 configuration
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001197)
Ralf (reporter)
2008-05-16 19:10

problem also exists with Endian 2.2 rc1
(0002079)
ra-endian (administrator)
2009-03-24 09:56

this problem still exists with 2.2 rc3 ?
(0002085)
Ralf (reporter)
2009-03-24 21:23

yes - I just tried 2.2 rc3 and the same error messages occured
(0002386)
brycedunn (reporter)
2009-05-27 00:43

I found a workaround to this issue.

When you first boot the system (before you answer any of its questions), do Alt F3, so you can run commands.
then type:
# modprobe cpqarray
(this will load the correct module, for the Compaq hardware)
Alt F2 - check the log output and ensure its loaded
Alt F1, continue the install.
(0002439)
peter-endian (administrator)
2009-05-29 16:52

i upgraded hwdata and kudzu in the installer's initrd or 2.3,. I hope this fixes that problem.
At least I think so, since compaq's arrays are included

I can't test it, since I have no machine, but i will resolve the ticket for now.
Can you test with beta2, when it is released and reopen if it did not solve?

Thank's
(0002443)
Ralf (reporter)
2009-05-30 11:23
edited on: 2009-05-30 11:24

Thanks for the workaround.

Installation of Endian 2.2 runs with this workaround without any error messages. The only drawback is that there is no swap space created.

During the boot process the following messages are displayed:
Unable to find swap-space signature
Swapon: /dev/ida/c0d0p2 Invalid argument

The firewall runs at this moment without swap space …

Thanks
Ralf

(0002444)
mike-f (updater)
2009-05-30 11:43
edited on: 2009-05-30 12:26

please post your /etc/fstab

(0002445)
Ralf (reporter)
2009-05-30 12:17

/dev/ida/c0d0p1 /boot ext3 nodev,nosuid,noatime 1 2
/dev/ida/c0d0p3 / ext3 noatime 1 1
/dev/ida/c0d0p4 /var ext3 noatime,mand 1 1
none /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/ida/c0d0p2 none swap sw 0 0
(0002446)
mike-f (updater)
2009-05-30 12:27

try a
# mkswap /dev/ida/c0d0p2

if it doesn't help plz post the output of
# sfdisk -l /dev/ida/c0d0
(0002447)
Ralf (reporter)
2009-05-30 12:43

the response of
mkswap /dev/ida/c0d0p2
was
Setting up swapspace version 1, size = 2118201 kB

I did a reboot and every think looks good. I've 2G swap space.

Thanks
Ralf



####################
cat /etc/fstab shows now
####################
/dev/ida/c0d0p1 /boot ext3 nodev,nosuid,noatime 1 2
/dev/ida/c0d0p3 / ext3 noatime 1 1
/dev/ida/c0d0p4 /var ext3 noatime,mand 1 1
none /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/ida/c0d0p2 none swap sw 0 0


#######################
sfdisk -l shows now
#######################
Disk /dev/ida/c0d0: 4355 cylinders, 255 heads, 32 sectors/track
Units = cylinders of 4177920 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start End #cyls #blocks Id System
/dev/ida/c0d0p1 * 0+ 7 8- 32639+ 83 Linux
/dev/ida/c0d0p2 8 514 507 2068560 82 Linux swap / Solaris
/dev/ida/c0d0p3 515 1794 1280 5222400 83 Linux
/dev/ida/c0d0p4 1795 4354 2560 10444800 83 Linux
(0002495)
peter-endian (administrator)
2009-06-08 16:32

i resolve this ticket, since the necessary changes have been done in 2.3.
please test it on 2.3 when released and reopen if it happens there again.

- Issue History
Date Modified Username Field Change
2008-04-11 10:21 Ralf New Issue
2008-05-16 19:10 Ralf Note Added: 0001197
2009-03-24 09:56 ra-endian Note Added: 0002079
2009-03-24 09:56 ra-endian Assigned To => ra-endian
2009-03-24 09:56 ra-endian Status new => feedback
2009-03-24 21:23 Ralf Note Added: 0002085
2009-05-27 00:43 brycedunn Note Added: 0002386
2009-05-27 06:21 ra-endian Status feedback => new
2009-05-27 06:21 ra-endian Assigned To ra-endian => peter-endian
2009-05-27 09:25 peter-endian Relationship added child of 0001873
2009-05-27 09:54 peter-endian Target Version => 2.3
2009-05-29 16:52 peter-endian Note Added: 0002439
2009-05-29 16:52 peter-endian Status new => resolved
2009-05-29 16:52 peter-endian Fixed in Version => 2.3
2009-05-29 16:52 peter-endian Resolution open => fixed
2009-05-30 11:23 Ralf Note Added: 0002443
2009-05-30 11:23 Ralf Status resolved => feedback
2009-05-30 11:23 Ralf Resolution fixed => reopened
2009-05-30 11:23 Ralf Note Edited: 0002443
2009-05-30 11:24 Ralf Note Edited: 0002443
2009-05-30 11:24 Ralf Note Edited: 0002443
2009-05-30 11:43 mike-f Note Added: 0002444
2009-05-30 11:47 mike-f Note Edited: 0002444
2009-05-30 12:17 Ralf Note Added: 0002445
2009-05-30 12:26 mike-f Note Edited: 0002444
2009-05-30 12:27 mike-f Note Added: 0002446
2009-05-30 12:43 Ralf Note Added: 0002447
2009-06-08 16:32 peter-endian Note Added: 0002495
2009-06-08 16:32 peter-endian Status feedback => resolved
2009-06-08 16:32 peter-endian Resolution reopened => fixed
2009-10-27 12:00 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker