SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000699: Smart-host will be classified as SPAM - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000699Endian FirewallOther Servicespublic2008-04-22 12:302009-10-27 12:04
ReportermichaelF 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta3 
Target VersionFixed in Version2.2-rc1 
Summary0000699: Smart-host will be classified as SPAM
DescriptionIf i use the SMTP-Proxy (even with smarthost) the e-Mail will be classified as SPAM (eg. at web.de or gmx.de). I suppose, this is because of some additional line in the mail header:

Part of WRONG Header:

Received: from xdsl-87-78-206-86.netcologne.de (HELO ?87.78.206.86?) (87.78.206.86)
by www.finanzpartner.de with (DHE-RSA-AES256-SHA encrypted) SMTP; 22 Apr 2008 14:20:44 +0200
Received: from localhost (localhost [127.0.0.1])
by efw.localdomain (Postfix) with ESMTP id 8B86711D4434
for <freund-siegburg@web.de>; Tue, 22 Apr 2008 14:20:44 +0200 (CEST)
X-Virus-Scanned: by Endian Firewall
Received: from [127.0.0.1] (unknown [192.168.62.59])
by efw.localdomain (Postfix) with ESMTP id 3C4CF11D4433
for <freund-siegburg@web.de>; Tue, 22 Apr 2008 14:20:43 +0200 (CEST)

The same e-Mail without this lines is classiffied as no SPAM:

Received: from xdsl-87-78-206-86.netcologne.de (HELO ?127.0.0.1?) (87.78.206.86)
by www.finanzpartner.de with SMTP; 22 Apr 2008 14:17:58 +0200
TagsNo tags attached.
Attached Files? file icon efw-smtpd-2.4.34-0.endian10.noarch.rpm [^] (15,072 bytes) 2008-04-24 09:43

- Relationships
related to 0000712closedpeter-endian restartsmtpd: postfix will not start if smtp_helo_name is an ip address 

-  Notes
(0001037)
peter-endian (administrator)
2008-04-24 09:39

ouch. missing [] in helo
it's fixed now. i will attach the current rpm

- Issue History
Date Modified Username Field Change
2008-04-22 12:30 michaelF New Issue
2008-04-24 09:39 peter-endian Note Added: 0001037
2008-04-24 09:39 peter-endian Assigned To => peter-endian
2008-04-24 09:39 peter-endian Status new => confirmed
2008-04-24 09:40 peter-endian Relationship added related to 0000712
2008-04-24 09:43 peter-endian File Added: efw-smtpd-2.4.34-0.endian10.noarch.rpm
2008-04-24 09:43 peter-endian Status confirmed => resolved
2008-04-24 09:43 peter-endian Fixed in Version => 2.2-rc1
2008-04-24 09:43 peter-endian Resolution open => fixed
2009-10-27 12:04 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker