SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000710: enable to configure http proxy - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000710Endian FirewallApplication Level Proxiespublic2008-04-23 17:562009-10-27 12:03
Reporterdexters84 
Assigned Tosimon-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta4 
Target VersionFixed in Version2.2-rc1 
Summary0000710: enable to configure http proxy
DescriptionAfter a clean install of EFW ver. 2.2 beta4 I'm unable to configure http proxy.
After clicking button save changes on configuration page of http proxy I receive red colored message saying
Default settings are not defined.
Furthermore if I go to default policy settings and I try to change rules from unrestricted to anything else - doesn't metter if it is content scanning or antivirus - nothing changes.
Additional InformationI did a tail -f /var/log/messages when doing described actions and when I've executed one of the commands from log:
/usr/local/bin/restartdansguardian.py

I've received the following error:
# Error reading config /var/efw/dansguardian/default/settings
# Error reading config /var/efw/dansguardian/settings
['/var/efw/dansguardian/default']
['/var/efw/dansguardian/default']
# Error reading config /var/efw/dansguardian/default/default/settings
# Error reading config /var/efw/dansguardian/default/settings
TagsNo tags attached.
Attached Files? file icon efw-interfaceeditor-2.2.22-0.endian1.noarch.rpm [^] (12,936 bytes) 2008-04-24 15:18
? file icon efw-proxy-2.2.54-1.endian1.noarch.rpm [^] (72,539 bytes) 2008-04-24 15:18
? file icon efw-base-2.6.101-1.endian3.noarch.rpm [^] (95,590 bytes) 2008-04-24 17:02

- Relationships
has duplicate 0000734closedsimon-endian http-Proxy -- default policy 
child of 0000719closedsimon-endian no content filter policy after upgrade 2.2b3->2.2b4 

-  Notes
(0001027)
dexters84 (reporter)
2008-04-23 18:03

the title should be "unable to configure http proxy" - sorry for that
(0001028)
simon-endian (developer)
2008-04-23 18:06
edited on: 2008-04-23 18:10

- default policy rules cgi has a js bug which resets the settings before saving
- default settings not defined errormessage -> permissionproblem or emtpy file (/var/efw/proxy/settings) need to make fallback if settingsfile is empty

(0001031)
tethien (reporter)
2008-04-24 08:42
edited on: 2008-04-24 08:43

-default policy allway become "unrestricted" on rule 1
-I can create rule "content filter + antivirus scan" or "antivirus scan only" on rule 2. But if I move it to rule 1 it will become "unrestricted"!!!

(0001056)
simon-endian (developer)
2008-04-24 15:14

fixed the bug
-> restartscript did not find rule1 so he added defaultrule which deleted the original rule
-> fom.js did collide with js from defaultpolicy -> new proxyprofile.js fixed problem
-> cgi did not check if /var/efw/proxy/settings was empty -> now default settings are used if it is empty

i will add the rpms which should fix the problem.

thx for testing. it would be nice if you could inform me, if any of the problem inf bug 0000710 and 0000719 still occur.

greatz simon
(0001057)
simon-endian (developer)
2008-04-24 15:19

added rpms
(0001062)
wildchild (reporter)
2008-04-24 17:33

To get it to work for myself even after installing the updated packages I modified advproxy.cgi since /var/efw/proxy/profiles/default didnt exist.

        #check if default profiledir exists
- if (!-d "$profiledir/default") {
+ if (!-d "$profiledir/defaultprofile") {
            $errormessage = _("Default settings are not defined.")
        }
        else {
            system("/usr/local/bin/restartsquid --force");
        }
(0001063)
simon-endian (developer)
2008-04-24 17:43

thx, will fix this.

simon
(0001073)
tethien (reporter)
2008-04-25 07:04

Can't change Authentication type to "none" ?
In the list only have Local, LDAP, Windows, Radius !!!
(0001074)
ra-endian (administrator)
2008-04-25 07:20

please choose "no authentication" or "transparent" on green or blue or orange ( Proxy->HTTP->Configuration )
(0001075)
tethien (reporter)
2008-04-25 08:28

in that case. i think you can disable Authentication type if choosed "no authentication" or "transparent"

- Issue History
Date Modified Username Field Change
2008-04-23 17:56 dexters84 New Issue
2008-04-23 18:03 dexters84 Note Added: 0001027
2008-04-23 18:06 simon-endian Note Added: 0001028
2008-04-23 18:06 simon-endian Assigned To => simon-endian
2008-04-23 18:06 simon-endian Status new => confirmed
2008-04-23 18:10 simon-endian Note Edited: 0001028
2008-04-24 08:37 tethien Note Added: 0001030
2008-04-24 08:38 tethien Note Deleted: 0001030
2008-04-24 08:42 tethien Note Added: 0001031
2008-04-24 08:43 tethien Note Edited: 0001031
2008-04-24 13:21 simon-endian Relationship added child of 0000719
2008-04-24 15:14 simon-endian Status confirmed => resolved
2008-04-24 15:14 simon-endian Fixed in Version => 2.2-rc1
2008-04-24 15:14 simon-endian Resolution open => fixed
2008-04-24 15:14 simon-endian Note Added: 0001056
2008-04-24 15:16 simon-endian Status resolved => feedback
2008-04-24 15:16 simon-endian Resolution fixed => reopened
2008-04-24 15:17 simon-endian File Added: efw-base-2.6.100-1.endian3.noarch.rpm
2008-04-24 15:18 simon-endian File Added: efw-interfaceeditor-2.2.22-0.endian1.noarch.rpm
2008-04-24 15:18 simon-endian File Added: efw-proxy-2.2.54-1.endian1.noarch.rpm
2008-04-24 15:19 simon-endian Status feedback => resolved
2008-04-24 15:19 simon-endian Resolution reopened => fixed
2008-04-24 15:19 simon-endian Note Added: 0001057
2008-04-24 17:02 simon-endian Status resolved => feedback
2008-04-24 17:02 simon-endian Resolution fixed => reopened
2008-04-24 17:02 simon-endian File Deleted: efw-base-2.6.100-1.endian3.noarch.rpm
2008-04-24 17:02 simon-endian File Added: efw-base-2.6.101-1.endian3.noarch.rpm
2008-04-24 17:04 simon-endian Status feedback => resolved
2008-04-24 17:04 simon-endian Resolution reopened => fixed
2008-04-24 17:33 wildchild Status resolved => feedback
2008-04-24 17:33 wildchild Resolution fixed => reopened
2008-04-24 17:33 wildchild Note Added: 0001062
2008-04-24 17:43 simon-endian Note Added: 0001063
2008-04-24 17:43 simon-endian Status feedback => assigned
2008-04-25 07:04 tethien Note Added: 0001073
2008-04-25 07:20 ra-endian Note Added: 0001074
2008-04-25 08:28 tethien Note Added: 0001075
2008-05-02 13:34 simon-endian Relationship added has duplicate 0000734
2008-05-02 13:35 simon-endian Status assigned => resolved
2008-05-02 13:35 simon-endian Resolution reopened => fixed
2009-10-27 12:03 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker