SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000761: Kernel or openvpn bug ? - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000761Endian FirewallHardware related (kernel, drivers, hardware)public2008-05-06 14:372009-10-27 12:03
ReporterThomas Heimann 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta4 
Target VersionFixed in Version2.2-rc1 
Summary0000761: Kernel or openvpn bug ?
DescriptionHi

I got this twice today in /var/log/messages:

May 6 12:12:21 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:12:31 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:12:41 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:12:52 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:02 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:12 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:22 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:32 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:42 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:13:53 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
May 6 12:14:03 gate kernel: unregister_netdevice: waiting for tap1 to become free. Usage count = -7
------------------------------
and so on.

Corresponding to that in openvpn.log:
---------------------------------------------------------------------
May 6 12:12:05 gate openvpn[3240]: event_wait : Interrupted system call (code=4)
May 6 12:12:05 gate openvpn[3240]: OpenVPN CLIENT LIST
May 6 12:12:05 gate openvpn[3240]: Updated,Tue May 6 12:12:05 2008
May 6 12:12:05 gate openvpn[3240]: Common Name,Real Address,Bytes Received,Bytes Sent,Connected Since
May 6 12:12:05 gate openvpn[3240]: ROUTING TABLE
May 6 12:12:05 gate openvpn[3240]: Virtual Address,Common Name,Real Address,Last Ref
May 6 12:12:05 gate openvpn[3240]: GLOBAL STATS
May 6 12:12:05 gate openvpn[3240]: Max bcast/mcast queue length,1
May 6 12:12:05 gate openvpn[3240]: END
May 6 12:12:05 gate openvpn[3240]: event_wait : Interrupted system call (code=4)
May 6 12:12:05 gate openvpn[3240]: /sbin/ip addr flush dev tap1
----------------------------------------------------------------------
or
----------------------------------------------------------------------
May 5 21:53:45 gate openvpn[3226]: event_wait : Interrupted system call (code=4)
May 5 21:53:45 gate openvpn[3226]: OpenVPN CLIENT LIST
May 5 21:53:45 gate openvpn[3226]: Updated,Mon May 5 21:53:45 2008
May 5 21:53:45 gate openvpn[3226]: Common Name,Real Address,Bytes Received,Bytes Sent,Connected Since
May 5 21:53:45 gate openvpn[3226]: ROUTING TABLE
May 5 21:53:45 gate openvpn[3226]: Virtual Address,Common Name,Real Address,Last Ref
May 5 21:53:45 gate openvpn[3226]: GLOBAL STATS
May 5 21:53:45 gate openvpn[3226]: Max bcast/mcast queue length,1
May 5 21:53:45 gate openvpn[3226]: END
-----------------------------------------------------------------------

After that Squid/HAVP is working fine but smtp proxy doesn't answer to internal and external requests. A reboot hangs with messages above on the console.
Only a hard reset helps.

Thomas
TagsNo tags attached.
Attached Files? file icon openvpn-2.1-0.endian13.i586.rpm [^] (211,083 bytes) 2008-05-06 14:47

- Relationships

-  Notes
(0001124)
ra-endian (administrator)
2008-05-06 14:48

please try this update. This upgrade should fix the issue.
(0001125)
Thomas Heimann (reporter)
2008-05-06 16:12

OK. Thanks!
(0001127)
Thomas Heimann (reporter)
2008-05-07 05:34

Seems to be fixed. Thanks again!

- Issue History
Date Modified Username Field Change
2008-05-06 14:37 Thomas Heimann New Issue
2008-05-06 14:43 ra-endian Assigned To => ra-endian
2008-05-06 14:43 ra-endian Status new => confirmed
2008-05-06 14:47 ra-endian File Added: openvpn-2.1-0.endian13.i586.rpm
2008-05-06 14:48 ra-endian Note Added: 0001124
2008-05-06 16:12 Thomas Heimann Note Added: 0001125
2008-05-07 05:34 Thomas Heimann Note Added: 0001127
2008-05-07 08:09 ra-endian Status confirmed => resolved
2008-05-07 08:09 ra-endian Fixed in Version => 2.2-rc1
2008-05-07 08:09 ra-endian Resolution open => fixed
2009-10-27 12:03 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker