SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000770: uplinkeditor.cgi loops for ever, so selecting "Interfaces" on the Network tab stalls. - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000770Endian FirewallNetwork related (VPN, uplinks)public2008-05-07 14:322008-07-27 20:18
Reporterjsalgado 
Assigned Tosimon-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta4 
Target VersionFixed in Version2.2-rc2 
Summary0000770: uplinkeditor.cgi loops for ever, so selecting "Interfaces" on the Network tab stalls.
DescriptionI set up 2 pppoe uplinks, and then tried to apply the "if this linkg goes down.. " checkbox , then both links went down, and the manager webpages looped with no results.

I logged via ssh and saw uplinkeditor.cgi on 99% CPU LOAD, i waited for an hour and the process never ended.

There was no way to access the uplinks to delete or modify anything. until I went to the network wizard and set the red interface to static. Then uplinks became accesible but they both kind of lost their config.
TagsNo tags attached.
Attached Files? file icon efw-configroot-2.2.47.test3-0.endian7.noarch.rpm [^] (29,466 bytes) 2008-05-15 08:35
? file icon efw-interfaceeditor-2.2.23.test29-0.endian1.noarch.rpm [^] (13,254 bytes) 2008-05-15 08:35

- Relationships

-  Notes
(0001173)
simon-endian (developer)
2008-05-15 08:33

happens when uplink1 is backup of uplink2 and uplink2 is backup of uplink1
(0001174)
simon-endian (developer)
2008-05-15 08:37

i fixed the bug and attached 2 rpms.
could you install them and test if it works now?

greatz simon
(0001184)
jsalgado (reporter)
2008-05-15 17:33

Thank you very much Simon, I have instaled both rpms, and made some tests.

I may confirm the issue is solved. I tested with my system, and I have no more infinite loop on the uplink web tab.

good job! =)

- Issue History
Date Modified Username Field Change
2008-05-07 14:32 jsalgado New Issue
2008-05-07 14:32 jsalgado Status new => assigned
2008-05-07 14:32 jsalgado Assigned To => peter-endian
2008-05-07 14:45 ra-endian Assigned To peter-endian => simon-endian
2008-05-14 11:26 simon-endian Reproducibility have not tried => unable to reproduce
2008-05-15 08:33 simon-endian Note Added: 0001173
2008-05-15 08:33 simon-endian Reproducibility unable to reproduce => always
2008-05-15 08:35 simon-endian File Added: efw-configroot-2.2.47.test3-0.endian7.noarch.rpm
2008-05-15 08:35 simon-endian File Added: efw-interfaceeditor-2.2.23.test29-0.endian1.noarch.rpm
2008-05-15 08:37 simon-endian Status assigned => resolved
2008-05-15 08:37 simon-endian Fixed in Version => 2.2
2008-05-15 08:37 simon-endian Resolution open => fixed
2008-05-15 08:37 simon-endian Note Added: 0001174
2008-05-15 17:33 jsalgado Status resolved => feedback
2008-05-15 17:33 jsalgado Resolution fixed => reopened
2008-05-15 17:33 jsalgado Note Added: 0001184
2008-05-15 17:34 jsalgado Status feedback => resolved
2008-05-15 17:34 jsalgado Resolution reopened => fixed
2008-07-24 15:55 ra-endian Fixed in Version 2.2 => 2.2-rc2
2008-07-27 20:18 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker