SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000771: "Add external access" on Port forwarding configuration Broken. Supports only one IP address - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000771Endian FirewallFirewall (iptables)public2008-05-08 07:012009-10-27 12:03
Reporterjsalgado 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta4 
Target VersionFixed in Version2.2-rc1 
Summary0000771: "Add external access" on Port forwarding configuration Broken. Supports only one IP address
DescriptionThis means, you have to choose to set incoming port forwarding rules for ALL the internet addresses in the world, or just to single ONE!

"Add external access" on Port forwarding configuration is broken from the second "external address" and on. The error is "Port XXXX is al ready in use". So We may have just one "Source IP, or network". And when this fails, the wizard shows the whole PortForwarding Form, not just the "external address" one. It seem like the interface tries to re-write the whole rule instead of just adding the second "Source IP, or network"
Additional InformationI didnt mark the severity on MAYOR, beacause "Add external access" isnt popular enough, but this is a real BUG, since most people using this feature need off course more than just one single allowed address per port.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2008-05-08 07:01 jsalgado New Issue
2008-05-08 07:01 jsalgado Status new => assigned
2008-05-08 07:01 jsalgado Assigned To => peter-endian
2008-05-08 08:56 peter-endian Status assigned => resolved
2008-05-08 08:56 peter-endian Fixed in Version => 2.2-rc1
2008-05-08 08:56 peter-endian Resolution open => fixed
2009-10-27 12:03 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker