SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000799: Gui firewall mesaj Firewall rules have been changed and need to be applied in order to make the changes active - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000799Endian FirewallGUIpublic2008-05-14 07:132008-07-27 20:18
Reportermormogeacl 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc1 
Target Version2.2-rc2Fixed in Version2.2-rc2 
Summary0000799: Gui firewall mesaj Firewall rules have been changed and need to be applied in order to make the changes active
DescriptionMesaj persist Firewall rules have been changed and need to be applied in order to make the changes active
TagsNo tags attached.
Attached Filesjpg file icon gui firewall1.JPG [^] (215,462 bytes) 2008-05-14 07:13


jpg file icon output.JPG [^] (142,646 bytes) 2008-05-14 11:20

- Relationships
parent of 0000929closedpeter-endian csvfile class need to ignore carriage returns 

-  Notes
(0001160)
peter-endian (administrator)
2008-05-14 10:44

could you please start within console:

setportfw.py --debug

and send us the output?

and please send me the output of:
grep setportfw /etc/sudoers
(0001167)
peter-endian (administrator)
2008-05-14 13:48

oh, that's interesting

could you please attach:

cat /var/efw/portfw/config

did you restore an older backup?
(0001168)
mormogeacl (reporter)
2008-05-14 15:47
edited on: 2008-05-15 05:15

yes restore a backup

root@endian:~ # cat /var/efw/portfw/config
,,0,tcp,53,172.28.12.2,53,on,192.168.1.102,0.0.0.0/0,,UPLINK:main,off
,,0,udp,53,172.28.12.2,53,on,192.168.1.102,0.0.0.0/0,,UPLINK:main,off
,,0,tcp,80,172.28.1.10,80,on,192.168.1.10,0.0.0.0/0,,UPLINK:main,off
4,0,tcp,21,172.28.1.10,21,on,192.168.1.10,0.0.0.0/0,,UPLINK:main,on,off
root@endian:~ #

(0001187)
peter-endian (administrator)
2008-05-15 19:33

that format is wrong. however i cannot reproduce how this can be happen.
could you please attach the file /var/efw/portfw/config ?
i think somehow it managed it to contain invalid characters
(0001303)
peter-endian (administrator)
2008-06-11 08:59

the problem is:
the last field does not containt 'off', but 'off\r'

no idea how this can happen -> Csvfile class need to ignore carriage returns

- Issue History
Date Modified Username Field Change
2008-05-14 07:13 mormogeacl New Issue
2008-05-14 07:13 mormogeacl File Added: gui firewall1.JPG
2008-05-14 10:44 peter-endian Note Added: 0001160
2008-05-14 11:20 mormogeacl File Added: output.JPG
2008-05-14 13:48 peter-endian Note Added: 0001167
2008-05-14 15:47 mormogeacl Note Added: 0001168
2008-05-15 05:15 mormogeacl Note Edited: 0001168
2008-05-15 18:08 peter-endian Target Version => 2.2
2008-05-15 19:33 peter-endian Note Added: 0001187
2008-05-15 20:03 peter-endian Status new => assigned
2008-05-15 20:03 peter-endian Assigned To => peter-endian
2008-06-03 10:06 peter-endian Target Version 2.2 => 2.2-rc2
2008-06-11 08:59 peter-endian Note Added: 0001303
2008-06-11 09:02 peter-endian Issue cloned: 0000929
2008-06-11 09:02 peter-endian Relationship added parent of 0000929
2008-06-16 15:05 peter-endian Status assigned => resolved
2008-06-16 15:05 peter-endian Fixed in Version => 2.2-rc2
2008-06-16 15:05 peter-endian Resolution open => fixed
2008-07-27 20:18 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker