SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000811: No Whitelist for spamassassin within SMTP-Proxy - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000811Endian FirewallApplication Level Proxiespublic2008-05-15 10:132009-10-27 12:00
Reportermarkus 
Assigned Tosimon-endian 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta4 
Target Version2.3Fixed in Version2.3 
Summary0000811: No Whitelist for spamassassin within SMTP-Proxy
Descriptionefw marks mails from whitelisted e-mail-addresses as spam
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001179)
peter-endian (administrator)
2008-05-15 11:12

the whitelists are for rbl blacklists only

spamassassin does not obey those whitelists, because it has it's own.
currently unfortunately there is no possibility to configure a whitelist for spamassassin
(0001712)
luca-endian (developer)
2008-10-15 21:52

A solution to avoid this issue is to manually modify spamassassin configuration file.
WARNING this is intended only for advanced users who know what they are doing!!
The file to edit is /etc/spamassassin/local.cf.tmpl you have to append lines like this:
whitelist_from *@google.com

here more info about spammassassin whitelist http://wiki.apache.org/spamassassin/ManualWhitelist [^]

This hack works on 2.1 and 2.2 systems, but an update may reset this configuration.
(0002032)
simon-endian (developer)
2009-03-13 09:47

it is now possible to define sender black and whitelist for spamassasin

- Issue History
Date Modified Username Field Change
2008-05-15 10:13 markus New Issue
2008-05-15 11:12 peter-endian Note Added: 0001179
2008-05-15 11:13 peter-endian Status new => confirmed
2008-05-15 11:13 peter-endian Target Version => 2.2
2008-05-19 10:17 peter-endian Summary Whitelist for SMTP-Proxy does not work => No Whitelist for spamassassin within SMTP-Proxy
2008-09-10 15:41 chris-endian Target Version 2.2 => 2.3
2008-09-10 16:03 chris-endian Target Version 2.3 => future
2008-10-15 21:52 luca-endian Note Added: 0001712
2009-02-16 17:51 peter-endian Target Version future => 2.3
2009-02-16 17:52 peter-endian Status confirmed => new
2009-02-16 17:52 peter-endian Assigned To => simon-endian
2009-02-26 11:40 peter-endian Priority normal => high
2009-03-13 09:47 simon-endian Note Added: 0002032
2009-03-13 09:47 simon-endian Status new => resolved
2009-03-13 09:47 simon-endian Fixed in Version => 2.3
2009-03-13 09:47 simon-endian Resolution open => fixed
2009-10-27 12:00 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker