SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000865: Ethernet connection NOT stable on IBM Server - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000865Endian FirewallHardware related (kernel, drivers, hardware)public2008-05-24 13:072009-10-27 12:02
Reportertethien 
Assigned Topeter-endian 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc1 
Target VersionFixed in Version2.3 
Summary0000865: Ethernet connection NOT stable on IBM Server
DescriptionI am testing Endian 2.2 rc1 on IBM xSeries 346 server.
The ethernet connection is NOT stable!!! It connect then disconnect all day.
I tested cable, other device ... all of it is OK.
TagsNo tags attached.
Attached Filestxt file icon dmesg_out.txt [^] (122,966 bytes) 2008-08-04 05:30 [Show Content]
rar file icon messages.rar [^] (124,687 bytes) 2008-08-04 05:37

- Relationships

-  Notes
(0001228)
tethien (reporter)
2008-05-24 13:12
edited on: 2008-05-24 13:13

Endian 2.2 beta 3 not have this bug. It run well on this server.
I not install endian 2.2 beta 4.

(0001230)
peter-endian (administrator)
2008-05-26 13:17

Can you please send us the output of

dmesg

and check in /var/log/messages if you see something suspect before the reboot?
(0001234)
tethien (reporter)
2008-05-27 09:22
edited on: 2008-05-27 09:25

I am very sorry. I rollbacked to 2.2 beta 3.
I not saved any log file.

(0001496)
tethien (reporter)
2008-08-04 05:30

I am testing v2.2 RC2 and this bug repeated.
(0001587)
peter-endian (administrator)
2008-09-09 11:09

if you mean that the uplink is not stable, that's because of a configuration problem:
"pppd[16776]: In file /etc/ppp/peers/main: unrecognized option 'Pro'"

Don't know where this "Pro" comes from. But this hinders the uplink from connecting. The uplinksdaemon constantly tries to connect, therefore the ethernet link goes up and down all the time.
(0001631)
tethien (reporter)
2008-09-22 14:08

The "Pro" come from "Service:" value on Step 4/7 on Network setup wizard.
This value is "Mega Pro" !!!.
(0001633)
peter-endian (administrator)
2008-09-22 16:10

can you try to edit this file:
nano /usr/lib/uplinks/generic/pppoe.sh

search for "SERVICENAME"

and change this:
       echo "rp_pppoe_service $SERVICENAME" >> $PEERFILE
in that:
       echo "rp_pppoe_service \"$SERVICENAME\"" >> $PEERFILE

afterwards, the service name should be written down into the configuration file quoted with "".
(0001635)
tethien (reporter)
2008-09-23 07:55

OK.
After change /usr/lib/uplinks/generic/pppoe.sh file, edit Uplink, save, Uplink connection connected successfully.
(0001637)
peter-endian (administrator)
2008-09-23 10:23

great. i will integrate it

- Issue History
Date Modified Username Field Change
2008-05-24 13:07 tethien New Issue
2008-05-24 13:12 tethien Note Added: 0001228
2008-05-24 13:13 tethien Note Edited: 0001228
2008-05-26 13:17 peter-endian Note Added: 0001230
2008-05-26 13:17 peter-endian Status new => feedback
2008-05-27 09:22 tethien Note Added: 0001234
2008-05-27 09:25 tethien Note Edited: 0001234
2008-08-04 05:30 tethien Note Added: 0001496
2008-08-04 05:30 tethien File Added: dmesg_out.txt
2008-08-04 05:37 tethien File Added: messages.rar
2008-08-19 14:23 tethien Status feedback => closed
2008-08-19 14:23 tethien Resolution open => suspended
2008-09-09 11:09 peter-endian Note Added: 0001587
2008-09-09 11:09 peter-endian Status closed => feedback
2008-09-09 11:09 peter-endian Resolution suspended => reopened
2008-09-22 13:56 tethien Status feedback => closed
2008-09-22 13:56 tethien Resolution reopened => duplicate
2008-09-22 14:08 tethien Status closed => feedback
2008-09-22 14:08 tethien Resolution duplicate => reopened
2008-09-22 14:08 tethien Note Added: 0001631
2008-09-22 16:10 peter-endian Note Added: 0001633
2008-09-23 07:55 tethien Note Added: 0001635
2008-09-23 10:23 peter-endian Note Added: 0001637
2008-09-23 10:37 peter-endian Status feedback => resolved
2008-09-23 10:37 peter-endian Fixed in Version => 2.3
2008-09-23 10:37 peter-endian Resolution reopened => fixed
2008-09-23 10:37 peter-endian Assigned To => peter-endian
2009-10-27 12:02 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker