SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000009: Loss of Connectivity when RED Renews IP Address - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000009Endian FirewallGUIpublic2006-08-03 23:292007-12-31 19:15
ReporterTheAngryPenguin 
Assigned Topeter-endian 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2 
Target VersionFixed in Version2.2-beta2 
Summary0000009: Loss of Connectivity when RED Renews IP Address
Description(RED is set for DHCP) When either the RED connection is interrupted, or when it's issued a new DHCP lease, connectivity from GREEN to RED is broken. Sometimes disabling/enabling the connection in the webgui will restore access, other times, a reboot is required.
TagsNo tags attached.
Attached Filestxt file icon dhcplog.txt [^] (2,855 bytes) 2007-02-26 11:57 [Show Content]
txt file icon dhcplog2.txt [^] (1,460 bytes) 2007-02-26 12:16 [Show Content]

- Relationships

-  Notes
(0000025)
TheAngryPenguin (reporter)
2006-08-21 17:48

Obviously, this is unacceptable behavior. What really boggles my mind is that this report is now aging over two weeks and has yet to even be acknowledged.
(0000063)
kisas (reporter)
2006-10-29 16:28

I have the same problem. Each day I have to Disable/Enable EFW to get the outgoing connection back.
(0000120)
golfers5 (reporter)
2007-01-17 11:58

I think i have similar problem! I cant get connection from DHCP to RED interface. How can i manual force renew IP on command line!
(0000124)
edurgut (reporter)
2007-01-21 17:48

You can run "dhclient" command.

example:
dhclient -q eth1

Is it enough?
(0000192)
barne (reporter)
2007-02-26 12:04
edited on: 2007-02-26 12:18

I share the same experince, not that often though, but at unconvenient times (vacations, result lost mail etc. for some days).

It seems to me when the renewal process is made it tries last working dhcp server ip, and my ISP (Swedish Bredbandsbolaget) is using a rather unusuall (?) ip 172.21.249.107. After trying for approx. 10 min it stops trying that ip and continue only to try 255.255.255.255 for eternity (!). I think it atleast should try both or the last working only. Sometimes it happens the ISP have a rather long disconnection and then I must manually restart from the endian webinterface from my local network.

I added my log.


I Also added the log when I manually restarted the dhcpclient. Weird info for me...

Please correct this as soon as possible.

(I'm using Endian 2.0 comunity)

(0000194)
peter-endian (administrator)
2007-02-27 10:27

dhcplog1 shows that the dhcp server is unreachable and there is no working lease, so it can't be set up.
are you sure the problem does not lie between firewall and your provider? is the modem working correctly? is the dhcp server on providers side up?
does it continue working always if you reboot? or may this be that the modem or provider accidently come back after the reboot?

btw: you can force renew by simlpy disconnect/reconnect,
or /etc/rc.d/uplinks restart (that will reconnect after 30 seconds)
(0000195)
barne (reporter)
2007-02-27 11:07

As you see, my connection was lost on: Feb 19 03:09:03
I have tried to gain information from my ISP if they had any problems with their equipment at the time and in that case for how long time. No info so far though, they know nothing. I think it could have been be a shorter (<1 hour) disconnection, if it was longer my neighbour with the same ISP would know and he hasn´t noticed any break that day.

I was on vacation when my endian stopped, and arrived back home Feb 26 (one week after the break. The first thing I checked when I came home was all my equipment that is connected to the WAN (my ISP), everything was up (powered) and had been without any break (so no powerfailure had occured during the time away, in fact all equipment such as modem, servers, routers, IP-phone etc have been up and running for about 60 days since last reboot).

I get max 5 public IP's from my ISP, so after my modem (a Cisco VDSL) there is a Cisco VOIP-gateway-switch for the IP-phone and a included 4-port switch in it (for connecting computers and other equipment and gain public dynamic IP's for them, no NAT-routing, only switching!). The IP-phone has been working all the time I was away and hade a dynamic IP assigned. I also have another VOIP-set-top-box (i3micro VRG121) connected to one port of the VOIP-gateway-switch and that one was also working just fine with a public dynamic IP assigned.

To one of the ports in the VOIP-gateway-switch I have the Endian connected. That one lost/couldn't renew IP on Feb 19 03:09:03, and didn't manage to gain IP automatically for the whole week I was away.

The only thing I did when I came home was to start a computer in my LAN, connect to Endian webinterface, press "connect" on first page (it was a red lit "disconnected"). A few seconds later it had got a public IP from my ISP dhcp-server and everything was working just fine again.

I still havn´t toutched the modem (not rebooted it for months) so for me it seems to work like a charm. During last 3 months i think the endian has stopped working (renewing IP) for about 2-4 times, not many I know but still very anoying, especially when you are away for some days and then lose mail to your e-mailserver... My plan is now to set up a GSM-phone that reset power to endian via a SMS. Any other suggestion?

Any help?

It seems to me that the autmatic IP renew-function isn't working 100% (with my ISP anyway).
(0000196)
peter-endian (administrator)
2007-02-27 11:44

i see..
for now it's the only possibility to reconnect manually.
the reconnection routine is not 100% ok. we currently write a connection daemon which substitute the old routine and which will be more aggressive keeping up the uplink.
then the decision about reconnection or not will not be left anymore to the dhcp client, which in fact sometimes acts wrong if the dhcp server is not reachable for a while.
(0000645)
peter-endian (administrator)
2007-11-14 11:10

since 2.2beta1 dhclient tries only once to get an ip address from the dhcp server and exits then if it's not possible to get an address.
This issue should not happen again

- Issue History
Date Modified Username Field Change
2006-08-03 23:29 TheAngryPenguin New Issue
2006-08-21 17:48 TheAngryPenguin Note Added: 0000025
2006-10-29 16:28 kisas Note Added: 0000063
2007-01-17 11:58 golfers5 Note Added: 0000120
2007-01-21 17:48 edurgut Note Added: 0000124
2007-01-23 13:18 raphael-endian Status new => assigned
2007-01-23 13:18 raphael-endian Assigned To => peter-endian
2007-02-26 11:57 barne File Added: dhcplog.txt
2007-02-26 12:04 barne Note Added: 0000192
2007-02-26 12:06 barne Note Edited: 0000192
2007-02-26 12:16 barne File Added: dhcplog2.txt
2007-02-26 12:17 barne Note Edited: 0000192
2007-02-26 12:18 barne Note Edited: 0000192
2007-02-27 10:27 peter-endian Note Added: 0000194
2007-02-27 10:27 peter-endian Status assigned => feedback
2007-02-27 11:07 barne Note Added: 0000195
2007-02-27 11:44 peter-endian Note Added: 0000196
2007-10-28 14:36 peter-endian Priority normal => urgent
2007-11-14 11:10 peter-endian Status feedback => resolved
2007-11-14 11:10 peter-endian Fixed in Version => 2.2
2007-11-14 11:10 peter-endian Resolution open => fixed
2007-11-14 11:10 peter-endian Note Added: 0000645
2007-12-31 19:15 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker