SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000991: acls have same entries twice - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000991Endian FirewallProxy HTTPpublic2008-06-23 22:292008-07-27 20:18
Reporterpeter-endian 
Assigned Tosimon-endian 
PriorityimmediateSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc1 
Target Version2.2-rc2Fixed in Version2.2-rc2 
Summary0000991: acls have same entries twice
Descriptionin some circumstances, unsure how this can happen. It was a random configuration with many configuartion changes (routing editor, uplink editor, netwizard, http proxy) i faced warnings like these during restart of squid:


Stopping squid: 2008/06/24 00:24:46| WARNING: '10.0.0.0/255.255.255.0' is a subnetwork of '10.0.0.0/255.255.255.0'
2008/06/24 00:24:46| WARNING: because of this '10.0.0.0/255.255.255.0' is ignored to keep splay tree searching predictable
2008/06/24 00:24:46| WARNING: You should probably remove '10.0.0.0/255.255.255.0' from the ACL named 'from_src_blue'
2008/06/24 00:24:46| WARNING: '10.0.0.0/255.255.255.0' is a subnetwork of '10.0.0.0/255.255.255.0'
2008/06/24 00:24:46| WARNING: because of this '10.0.0.0/255.255.255.0' is ignored to keep splay tree searching predictable
2008/06/24 00:24:46| WARNING: You should probably remove '10.0.0.0/255.255.255.0' from the ACL named 'to_dst_blue'

This happens when an acl contains a subnet which is already defined in the same acl.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001437)
simon-endian (developer)
2008-07-14 13:35

duplicated subnet entries in the zone subnets acl files are now deleted when the proxy restarts

- Issue History
Date Modified Username Field Change
2008-06-23 22:29 peter-endian New Issue
2008-06-23 22:29 peter-endian Status new => assigned
2008-06-23 22:29 peter-endian Assigned To => simon-endian
2008-06-25 13:52 raphael-endian Priority normal => immediate
2008-07-14 13:35 simon-endian Status assigned => resolved
2008-07-14 13:35 simon-endian Fixed in Version => 2.2
2008-07-14 13:35 simon-endian Resolution open => fixed
2008-07-14 13:35 simon-endian Note Added: 0001437
2008-07-24 15:55 ra-endian Fixed in Version 2.2 => 2.2-rc2
2008-07-27 20:18 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker